January 25, 2017 Security Upgrade


The Teacher Regulation Branch (TRB) is aware of vulnerabilities with secure web communications based on hypertext transfer protocol (HTTP). The vulnerability affects all versions of Secure Socket Layer (SSL) and Transport Layer Security (TLS) prior to 1.2. The TRB is required to update the transport layer protocols to the recommended level of TLS 1.2 to mitigate these risks. This government-wide standard is meant to ensure that the most current, reliable protocols are being used to protect information.

If you are using an older web browser that does not support TLS 1.2, you will not be able to access the secure (HTTPS) areas of our website after the security upgrade.



Compatibility with your web browser version


The version of your web browser version cannot be determined. It may not be compatible with the security upgrade. View the list of TLS 1.2 supported web browsers.



List of TLS 1.2 supported web browsers


Chrome Logo Apple Safari 7 and higher
Chrome Logo Google Chrome version 40 and higher
Chrome Logo Microsoft Edge
Chrome Logo Microsoft Internet Explorer 11
Chrome Logo Mozilla Firefox version 35 and higher
Chrome Logo Opera Browser version 20 and higher